Ultima Online on MacBook



  • MadMartyrMadMartyr Posts: 61
    edited March 2022
    Just got a private message expressing a user's displeasure with PortingKit. I did eventually go back to Parallels as I again started having issues with the client refusing to connect. This is common in Wine environments, and it seemed that PortingKit had addressed it, but it did pop back up.

    Updated Recommendation

    For Intel-based Macs: Parallels with Windows 10 or 11 x64
    For ARM-based Macs: Parallels with Windows 11 ARM

    Guide for Installing Windows 11 ARM on M1 Macs with Parallels: Here
    UWF Emissary
    Developer of Ultima Mapper
  • I’m using Parallels for the classic client and everything works great. However, on my M1 Mac, I can’t get the enhanced client to work at all. Every time I patch it and go to launch the game, nothing happens. The enhanced client shows up in task manager but it never loads up. I’ve even tried adjusting the properties and windows version it uses.  Anybody have any thoughts on this?
  • fonsvitaefonsvitae Posts: 51
    edited January 2023
    I used Crossover for years to run the CC along with UOAssist & UOAM. Those were the good old days. It all came crashing to an end with the advent of the Mac Catalina OS...

    I have tried Parallels, Virtual Box and Boot Camp. For me, Boot Camp was the worst but all had issues with gameplay as compared with Crossover, which was seamless.

    Currently and since Catalina, Crossover will "hang" after shard selection. It is that one crucial point that it cannot get past consistently. I am not sufficiently knowledgable in softwares & server connections, but i do see that it is this server connection - some communication therein - which is where the problem lies. I have tried opening my firewall... so as to not limit any connection, but no dice. I am convinced that there is some kind of "handshake" at that point which is being missed: five pints of LB Ale to the sleuth who is able to figure this one out.

    Interestingly, though the game "hangs" at choosing the server, this only happens about 95% of the time: there is an occasional but rare instance of "getting through" and the game works as well as it ever did. Sadly, once logged out, good luck. It's back to 95 out of 100 answers that say: you can't get in. Somebody should be able to solve this. If it does work on rare occasion, if the problem is isolated to only that one point of choosing the server, this narrows things for a person with knowledge of this area... and to think, but for this, an otherwise perfectly working game.

    I believe the problem is with the "32 on 64" which Crossover instituted with Catalina's changes.... it works fine everywhere else but it ain't fooling nobody at server selection. This 32/64 was the only change to Crossover and server selection is the only place the problem occurs. Or maybe it is that the Mac is seeing through the sham at this point and refusing to cooperate with a 32 pretending to be a 64; I wonder.

    I contacted Crossover twice over a 1.5 to 2 year period, purchasing the product and filing a ticket: I was told both times that they would not solve it as the player base is too small to justify their staff's attention. This was related to me as an answer to when they would finally get around to looking at it, if not for immediate attention, then at least for eventual attention: never to highly not likely, with a strong leaning towards never.

    I still pay on my account though I haven't played in a few years. I am writing this message in the hopes that someone willing and able will run with it and see about how to solve it. 

  • I am on a MacBook, sounds easier to just get a Windows machine I guess, I am lazy, so lazy I cant even face renewing because its such a pain in the ass, unlike Windows which is just another pane in the glass.
  • I've been experiencing the same issues everyone else describes with Crossover and Portingkit but didn't want to pay for Parallels and so haven't been playing much UO in a while until this week!
    VMware just released Fusion Player 13.5 and I just got it up and running with the Classic Client and it's working great so far on my M1 Macbook Air. Since Fusion Player is free I had previously tried getting it running but couldn't figure out how to actually install Windows on the virtual machine. The new version now includes an option to auto-download Windows 11 ARM version which makes the installation and set up of the virtual machine pretty straight forward. Dealing with Windows 11  itself was dramatically more of a hassle than getting the virtual machine going (Windows 11 forces you to create a Microsoft account to use it, it's free but annoying.)
    I increased the virtual machine to 4 cores and 6GB of RAM which is probably more than needed to run one client at a time, haven't tested two yet. The cursor inside of UO was a little glitchy until I unchecked the "Run mouse in separate thread" option within UO itself. I also found that happily VMWare doesn't have the issue that Parallels does with control+shift not working. I've never used the EC so not sure if it works or not but I'll try to at least install it and report back if I have a chance

    tldr: new version of VMWare Fusion Player = free and relatively easy set up for playing UO on M1 Mac.

  • MadMartyrMadMartyr Posts: 61
    edited November 2023
    Just to check back in. The latest Windows update caused some funkiness with my Parallels VM, so I gave VMWare a chance again. One client runs smooth, but I usually run at least two. One for whatever I'm doing, and another hiding somewhere to resurrect me or waiting for a player or whatever. Once I opened the second client and logged in, even giving the VM 16GB of RAM and 5 CPU cores, everything started lagging and I was seeing graphics glitches. Nothing I've done seems to have alleviated that issue, so I'm back in Parallels. A few tweaks here and there to Windows system settings and disabling some unnecessary services, and it's running like new again.

    This is on a MacBook Pro M2 Max with 64GB of RAM. I really wanted VMWare to work well this time so I could throw more than 4 cores and 8GB of RAM (the hard limits in Parallels) at the VM, but it just wasn't meant to be.

    Your mileage may vary.
    UWF Emissary
    Developer of Ultima Mapper
  • MadMartyrMadMartyr Posts: 61
    edited November 2023
    @Lord_Taliesin If you disconnect the network adapter in the VM before the setting up Windows, you can install without logging in to a Microsoft Account. You need to run a command to bypass the network check, but I always do it when building VMs. For me, they're largely meant to be discarded after I complete a project, so I do it fairly often.
    UWF Emissary
    Developer of Ultima Mapper
Sign In or Register to comment.