Weapon special "Mystic Arc" on boomerang stopped working

LootdudeLootdude Posts: 15

I was using a clean (reforged) boomerang with no problems. Then the weapon special "mystic arc" stopped working yesterday. It does not damage multiple targets anymore when I activate it, only a single target.

Things I tried:
1. Equip another boomerang on original character, new boomerang works, so it must be the reforged one.
2. Move bugged boomerang to new character with throwing and tactics, reforged boomerang does NOT work, meaning my original thrower character is NOT bugged but the item.
3. Repair bugged boomerang: no change.
4. Apply POF on bugged boomerang: no change.
5. Change masteries on original character: no change.
6. Unequip/re-equip all items on original character: no change.
7. Die and resurrect on original character: no change.
8. Kill different mobs on different server zones and in different locations: no change.
8. Waiting for server reboot: no change.

I am at a loss at this point. 

I have never heard of a weapon working first and then becoming bugged. 
Also, I have no clue how it happened. 

I have burnt 1300 valorite hammer charges to get me that boomerang, a clean boomerang with maxed leeches and spell channeling.


  • MiskMisk Posts: 61Dev

    Lootdude said:
    Then the weapon special "mystic arc" stopped working yesterday.
    I have submitted a problem report into the system on this issue.
  • LootdudeLootdude Posts: 15
    Just a follow up.

    A GM fixed it (thanks!), that's the good news. 

    It worked for a while, but then the weapon got bugged again.

    I was casting chivalry spells and had enchant on (hit lightening 60%) and I was in wraith form fighting at the cyclopes pyramid. I think it has something to do with enchant, either when it wears off or when I equip another weapon (with enchant on the boomerang) and then re-equip the boomerang.

    Unfortunately, like last time, I was not able to find out when exactly the weapon got bugged because I noticed it only after a while. If you are not aggroed to mobs within range, mystic arch does not trigger on them, so you are damaging only the (one) mob that you attack. So I did not know if the weapon was already bugged or if I am simply not in the range of the other mobs or if I am not aggroed to them. 

    I did not page for a GM this time, as I think that even after fixing the boomerang for the 2nd time, it will sooner or later get bugged again, and then we are back at square one. 

    For other players, I suggest not to combine enchant weapon with mystic arch, which I believe is the source of the problem. I have never had any problems with my soul glaive (which is also spell channelling and got similar leeches on the weapon), so I guess it is a mystic arch problem. 

  • looploop Posts: 319
    edited November 2022
    Bumping this old thread, as I encountered it while taking a mystic thrower for a spin in Deceit :). Enchant Weapon appears to bug your boomerangs such that Mystic Arc no longer works.

    Thanks to GM Noctua for promptly resolving the issue.
  • Ok, thanks a lot for the feedback.

    It is likely that immolate weapon might cause this bug as well, although not tested. 
Sign In or Register to comment.