Losing items in house

So I’ve lost a few items here and there by being careless and not locking down containers in my house. Have you all been victim of losing stuff as well? I’ve lost some high dollar artifacts in the past. What’s the most expensive item you all have lost?

Most recently this is my issue. I converted my Large tower to a customizable home. In doing so my small soul forge became inaccessible for me to be able to pick up, lock down, secure, or release. It says it’s not in the house. My crafter was able to use it. I’m worried that when server wipes it will no longer be in my house. I’ve of course put in a help request and a bugged lost item request, but no GM response yet. That was last night. I have a feeling that I’m just going to be out millions…. Again…..


  • McDougleMcDougle Posts: 3,741
    You should be able to double click to retrieve 
    Acknowledgment and accountability go a long way... 
  • Lord_FrodoLord_Frodo Posts: 1,356
    Axe it
  • MandarkMandark Posts: 43
    Tried both. Didn’t work @McDougle and @Lord_Frodo.
  • Mandark said:
    Tried both. Didn’t work @ McDougle and @ Lord_Frodo.
    I don’t remember, can you change foundation style on a customized keep?
    A Goblin, a Gargoyle, and a Drow walk into a bar . . .

    Never be afraid to challenge the status quo

  • MariahMariah Posts: 2,403Moderator
    Not a keep, a large tower, so yes, change foundation might do the trick.
  • MandarkMandark Posts: 43
    @Victim_Of_Siege and @Mariah did that too and it didn’t work.
  • SoldahouseSoldahouse Posts: 129
    have you tried going into custom and putting walls where the forge is and see if it goes into the moving crate? 
  • PawainPawain Posts: 7,343
    edited August 2021
    Try the above tip.  It may pop under the sign if not in moving crate.

    If it is still there you are lucky.  It should have gone poof by now.

    Can you change the house to a different size, get the item, then change back?
  • MandarkMandark Posts: 43
    It was resolved. I’m assuming a GM helped me out maybe? But when I logged in it was in scroll form at my feet. Thank you all for all your suggestions. 
  • Lord_FrodoLord_Frodo Posts: 1,356
Sign In or Register to comment.