Mannequin not working

Can view stats on mannequin when he's naked,but when I switch clothes then click view suit stats nothing happens. Am I doing something wrong? Wont work on the 2 I have


  • Which account placed them?
    Usually I use co-owner account. So both owner and co-owner can use them.
  • PawainPawain Posts: 7,100
    Mine work fine.  As long as I am the account who placed it.
  • XrisXris Posts: 130
    I only have 1 account, and I placed them. Tried redeeding them several times and placing in different spots. I will try with a different set of armor, maybe something in this suit is bugged.
  • XrisXris Posts: 130
    so other armor sets worked fine, so i used process of elimination, and for some reason, this ring is what is causing it. Works fine without this ring equipped. I will report this in bug forum. 

  • PawainPawain Posts: 7,100
    Antique?  Or just that ring?
  • Please Test the ring on another armor set. And ring on mannequin solo.
  • PawainPawain Posts: 7,100
    edited January 2020
    I just had this happen.  The mannequin would not show stats with an imbued ring or bracelet.
    Garg jewels that were old.  

    Was a bug report made?
Sign In or Register to comment.