Paroxysmus Swamp Dragon just gone *poof*

I am aware this has been an on going issue and am not requesting for it to be replaced as I know the answer.  I thought it might help to share the circumstance of it disappearing.

First point was this was an old Swampie, at least 3-4 years old, now for the circumstance.

I was in Blackthorns dungeon killing the Captains and happened to have a little dirt nap and the Swampie was subsequently killed.  I made my way out to resurrect then headed back to recover my corpse and Swampie ghost, I then recalled out to get the Swampie resurrected.
It was a quiet time and there was no one resurrect it and there is the 10 minute timer before an NPC can do so.
So I then recalled to Serpents Hold stable, my usual spot.  I commanded the Paroxy Swampie to 'stay' and took out a backup normal Swamp Dragon.  I then returned to Blackthorns dungeon to finish the Captain I was engaged with.  After killing the Captain I recalled out to the Serpents Hold stable where my Paroxy Swampie no longer was.
I checked my followers which read 1/5 ie. the backup Swampie I was on, I then checked the stable and there was no sign of it.
Tried a few things, logging out/in to no avail, it's gone.  Could this per chance have something to do with the auto dismount/stable thing as you enter Blackthorns castle?  Just guessing.

So that was the circumstances, hopefully that info can go some way to fixing the issue which I know has affected many.  Thanks.


  • I can confirm this now, just recreated it on Test with a character from another realm!

    I killed my Paroxy Swampie by the stable, told it to stay, took a new mount out and headed to blackthorn.  Shows 2/5 pets at this stage.
    Walk in to the castle, you get dismounted and your pet count is reset to 0/5.
    Go to claim your pets and your Paroxy is gone, and it is not where you left it!!

    Can I get mine back now since i recreated the bug!?! :D
  • Further to my last, just tested this same thing with a Grizzled Mare, it also went *poof* not to be seen again.  Seems it affects all pets attained through statuettes/crystals etc.
  • PawainPawain Posts: 9,018
    edited October 2019
    Tested with a 16th Anniv Horse.  The video can be reproduced with any Statue pet. Including store bought pets.
    Focus on what you can do, not what you can't.
  • @Kyronix @Bleak The evidence of this is now stacking up and seems pretty conclusive.  Those that read this and the 'other' forum will be aware but many will not be aware and are still at risk of losing various mounts/pets with no recourse while this bug remains.

    Too many rare pets/mounts have been lost over the years, now we have it pinned down it needs addressed.
  • BleakBleak Posts: 143Dev
    Thank you for the details I will be looking into this issue.
  • PawainPawain Posts: 9,018
    Bleak said:
    Thank you for the details I will be looking into this issue.

    Make it so pets that start in Statue form do not leave the owner without a pop up screen Please.
    Focus on what you can do, not what you can't.
  • VioletViolet Posts: 368
    The issue is a little bit more complex.  If you have a living pet parked on a seperate subserver then go to anywhere that autostables your pet some weird things happen.

    I tried this with an alive CU parked in Luna and riding a nightmare into Blackthorns castle (5 control slots total).  The nightmare gets autostabled and follower count goes down to "0".  The CU is not stabled and usual pet retrival methods do not bring the CU back to you.    You can relog and use mooring lines and it will still show "0" followers and no CU.  You can also pull out a 5 slot pet and control it fine when the CU is in this status.  The only way to retrieve the pet is to actually find where it is in the world.  (you will not be able to control it if you are at max control slot count).

    So this bug is not limited to statue pets, but it seems statue pets are the only ones removed from the game.
  • PawainPawain Posts: 9,018
    Ok make all pets not leave the owner  without a pop up.  No more unbonding for any reason.

    The scenario above could be done accidentally and the player not understand that his first pet is not in the stable.  The pet could go wild or go poof if it was a statue because it may become unhappy.

    I have lost a Windrunner and a Skree that did not fit the OP scenario.  But I hope the fix for this will fix all the other ways pets have been lost.
    Focus on what you can do, not what you can't.
  • ForeverFunForeverFun Posts: 790
    edited June 2021
    Looks like easy to reproduce in the video.

    The server should be logging cases where "from statue" pets get deleted.  Then you could return them to the victim.
  • BilboBilbo Posts: 2,834
    Why has this bug been allowed to go on for so long when it can be reproduced 100%
  • YoshiYoshi Posts: 3,322
    edited February 2022
    "I just lost paroxysmus swamp dragon,

    I was working primevil on my sampire when some spawn and oranges dismounted me and killed my pets (then me), so i moved to teleporter in yellow, this took me to oasis champ on another subserver which teleported me to a shrine (because i was dead)

    I got ressed, mounted my ethereal horse and recalled to my house to get a PvP char, when i logged back on my sampire 15 mins later it showed only 1 follower, so i lost both paroxy swamp dragon and VvV mount (not bothered about vvv mount obv)

    Tried logging in/out, tried boarding ship, returned to champ area to search for dead pets, nothing

    GM Noctua could not locate"

    Posts on this account have been pre filtered from personal comment or opinion in an effort to suppress conservative views in order to protect the reader.
  • You checked termur stables ? sometimes it put the pet in nearest stable if your stables is full, but yea Ive lost a prepatch vollem the same way I got teleported from a champ area to a shrine, and it kicked my vollem out of the world , never saw it again
Sign In or Register to comment.