Mystical Polymorph Totem bugged

ZekeTerraZekeTerra Posts: 313
The Totems don't work on TC1.  You double click it after you add a costume and nothing happens.  If you double click it again it says you have to wait 25 seconds to use it again.  After you wait it still doesn't work.   Not sure if you put the last publish/patch on TC1 or not.


  • CinderellaCinderella Posts: 1,676
    after I read this, I tested mine that I had on test center.
    I had multiple ones in my backpack with the costumes in them & they all light up when you click on one of them. And none of them work
  • FaerylFaeryl Posts: 273
    I had that happen the last time I was on TC... about a week or so ago? I relogged and it was fine after.
  • I relogged, change characters, got fresh set of masks and totems and it was still not working.
  • BleakBleak Posts: 143Dev
    There was a change to the totems since the last update which requires you to get a new set on TC in order for them to function properly.
  • I did get a new set from the stone.  
  • BleakBleak Posts: 143Dev
    ZekeTerra said:
    I did get a new set from the stone.  
    The delivered items were updated this morning around the time of my previous post.
  • CinderellaCinderella Posts: 1,676
    edited November 2018
    ok thank you for letting us know.
    I had to use a different char than my main, cause she couldn't collect another set from the statue.
    however, once I had that bag, I was able to drop my old ones into that bag & they now work.

Sign In or Register to comment.