House Customizer moved a portrait and lost the handle

TimStTimSt Posts: 1,540
edited September 2018 in Homes & Castles

The other day I used the house customizer to add a missing floor tile. Afterwards I found that one of my portraits got moved from the third floor to the sign post.

It does not show as locked down

but acts like it because it has not decayed after several days.  It has no handle

It has no menu for me to use to retrieve it.

This is what shows when I use the "I wish to release this" command.

How do I retrieve that portrait so I can locate it properly?


  • CinderellaCinderella Posts: 1,543
    have you tried paging a GM?
  • TimStTimSt Posts: 1,540
    I paged a GM but then a non-GM player came to my aid.  The portrait disappeared from the sign post.  Have not found it yet.
  • GidgeGidge Posts: 413
    This is (was) a common occurrence. We had one in front of one of our homes for years. Just left it there. :)
  • This happens when the portrait has been turned using a deco tool. To retrieve the portrait it must be turned back, if possible. Otherwise, only a GM (or Devs) can move them.
  • I have one I turned on TC right now! It lost the handle right away so I couldnt turn it back . I tried to hide it behind a banner but it just didnt work. Glad it is TC..

Sign In or Register to comment.