Could not open file for writing: C:\Program Files (x86)....."

chankamanchankaman Posts: 4
edited May 2022 in Bugs
I'm a returned player. I install a UO on window 11 and I got a shield protected icon and I am sure what does it mean.
The problem is I can't save any setting I use in game. Whenever I log the game, every setting gone as default. I tried to use Ultima Online Classic Client. When I tried add a marco, the fetal error occured as the attached screen cap "Could not open file for writing: C:\Program Files (x86)....."

Could anyone help please?

Screen shot removed for security reasons - Mariah


  • YoshiYoshi Posts: 3,322
    edited May 2022
    “Windows 11…hmm
    Make sure you run uo in admin mode (right click the icon and click properties)
    disable/uninstall any third party antivirus you may have installed.
    Posts on this account have been pre filtered from personal comment or opinion in an effort to suppress conservative views in order to protect the reader.
  • chankamanchankaman Posts: 4
    Thank for the responding. But feel sorry that it doesn't work. I dont have any extra anti-virus and I have tried running in admin mode.

    I just fixed the problem in Classic Client by creating all the directories base on the error message.
    However, I found that the classic mode doesn't run smooth as the enhanced mode.   That's why I am still trying to fix the problem in enchanced client. 

    I also tried to create the diretories '\EA Games\Ultima Online Stygian Abyss\User Data\chankaman\Formosa\Mercury II' which didnt exist before. But it still doesn't work....

    Can I find that where the registery of the path of UOE Clinet is using?

  • McDougleMcDougle Posts: 3,742
    Uninstall everything then delete any leftover files. Now reinstall but allow it to run as administrator when the shield pops up say yes
    Acknowledgment and accountability go a long way... 
  • chankamanchankaman Posts: 4
    I tried reinstall UO Client 2 times, but it doesn't work.
    I think I need to re-install the whole windows OS again because I changed the local language of the OS before and I think it mixed up the path of the UO using when I found that UO installation used chinese language folder name.
    It is much more complicated that Hong Kong people are using two different kind of Chinese 
    Anyway, I will re-install Windows English Version and install UO firstly. 
  • ForeverFunForeverFun Posts: 852
    Running games as admin is crazy.
    For UO, you can change the permissions on the UO install directory to give yourself write access.  (you'll need to elevate to admin once to change the perms).
  • PawainPawain Posts: 9,288
    Probably your virus program.  Those mess up stuff often.
    Focus on what you can do, not what you can't.
  • Hi, I am getting same issue with my windows11 + English OS, could you share how you fix the error?

    Thank you!!
Sign In or Register to comment.