You may not use a soulstone in your current form

psychopsycho Posts: 296
I am getting this error message on one of my characters.
He tries to use a newly claimed soulstone fragment, but also real soulstones dont work.
Other characters on that account can use soulstones just fine.

Explain this one for me.

1: My character is in a house he own
2: Tried to lockdown the soulstone fragment, put it in a secure box. using a real soulstone instead of fragment.
3: Killed the char, resset up and tried using the soulstone again.
4: The character is not criminal
5: The character does not have necro but he had it previously. Anyway as the char was killed and ressed shouldnt any form go away after ressing up.
6: no ninjitu animal form on the character ever
7: Character is human, never been elf or gargoyle ever

7: Ive tried various soulstones, green, blue, red, fragment, all belong to that account and work fine on other characters.

I dont get it


  • CinderellaCinderella Posts: 1,702
    is that character wearing a costume?
    i had to unequip a fishing pole (the one that turns you into a goblin)
    before using one.
  • psychopsycho Posts: 296
    edited June 2021
    I thought of that too, should have said.

    I took off all armor and tried,  but no difference.

    thx for tip, i think character is just bugged.
    The caracter barely used for the past decade, but the implications means I have to train up a new skill to 115 instead of just soulstone it of the char. This is time consuming indeed and bugs bugs bugs
  • YoshiYoshi Posts: 3,322
    edited June 2021
    “You’re definitely not in vampiric embrace?
    do you receive an error message when you attempt to go into some sort of form such as polymorph?”
    Posts on this account have been pre filtered from personal comment or opinion in an effort to suppress conservative views in order to protect the reader.
  • psychopsycho Posts: 296
    edited June 2021
    Problem is fixed.
    I dont know what, when or how, but after being logged out for two hours all of a sudden it works.

    If any GM has been involved I say thank you!
    if not, its just funny

    I am a good customer also, today I bought 3x soulstone vessels (after the incident was fixed)
    But you guys need to work on the functionality, here you can see 16x soulstones in a vessel:

    No you dont, you can see 5 soulstones, but theres 16 in there.
    How can I pull out the right one withouth moving everything around in there.
    its bad functionality, but the art looks good.  (Just wish it changed color in the animation based on what color of the soulstone you have most of in there, I actually thought it did, but nope.)

    Feedback makes this game better.

  • dvviddvvid Posts: 849
    I could be mistaken but I believe I read the soul stone container is going to be fixed with an upcoming patch. 
Sign In or Register to comment.